Please if you find this site helpful & wish to help with it's funding. Thank You.


Author Topic: Hello all  (Read 1793 times)

0 Members and 1 Guest are viewing this topic.

IansSaph

  • Guest
Hello all
« on: December 28, 2007, 10:07:35 AM »
Good Morning and Merry Christmas,

I have a 24v in a 2wd saph cosworth, Bizzare transplant i know, bought it like that. its a bit of a messy install and was hoping for some knowledgable help in tidying this up untill the YB goes in, then some help in selling the motor would be great,

I'll get some pictures posted, i'm currently in the process of fitting the cosworth twin fans and standard rad and inter cooler back in. the stuck viscous fan has ment it hasn't really warmed up all month,

It has a starting issue, it will turn over tight and slow, sometimes speeding up and starting but sometimes needing a jump start, i have replaced the battery with new (twice as i took the first back thinking it was goosed) and it is charging at a health rate.

there is also a irregular knocking from the left bank cam case that stops when the vac pipe is pulled of the ERG....

Help.      Ian



Offline Taps

  • Hero Member
  • *****
  • Posts: 2983
  • Karma: +0/-0
    • http://www.fordpower.org.uk
Hello all
« Reply #1 on: December 28, 2007, 14:21:50 PM »
Welcome to Fordpower Ian

IansSaph

  • Guest
Hello all
« Reply #2 on: December 28, 2007, 14:42:23 PM »
cheers, any ideas on the above or should i restart in the 24v section?

Offline Taps

  • Hero Member
  • *****
  • Posts: 2983
  • Karma: +0/-0
    • http://www.fordpower.org.uk
Hello all
« Reply #3 on: December 28, 2007, 14:55:28 PM »
Quote from: IansSaph
cheers, any ideas on the above or should i restart in the 24v section?

Best to ask in there Ian as not many bother to look at the hello section as you might have noticed  

IansSaph

  • Guest
Hello all
« Reply #4 on: December 28, 2007, 15:06:34 PM »
 mmmm


Cheers

 

SMF spam blocked by CleanTalk