Please if you find this site helpful & wish to help with it's funding. Thank You.


Recent Posts

1
General Discussion / Re: Propshaft questions
« Last post by capri v8 driver on January 20, 2019, 19:31:10 PM »
There should be no noticeable play the joints or in the center rubber. I would start to have the prop shaft balanced. I would also check the engine and gearbox mounts and the angle the engine/gearbox sits against the diff. With a sierra you want 0 degrees in the first prop shaft and no more then 5 degrees in the second prop shaft.
2
Parts For Sale / Re: For sale emerald K6 wiring loom for 24v cosworth engine
« Last post by Ptgladstone on January 20, 2019, 18:59:18 PM »
Hi
   How much are you looking at for this loom please?
Regards
Rod

Hi Rod,

Sorry it’s now been sold, can make another if required
3
Hi Rob,

All got sold I am afraid
4
General Discussion / Propshaft questions
« Last post by scud on January 18, 2019, 19:55:27 PM »
Recently 2-3k miles ago I replaced the propshaft dohnut rubber on my Xr's rear prop with a custom spacer that allows use of the still available Cosworth item and at the same time I replaced the center support bearing, the rear uj seemed fine at the time.

during testing after that everything was fine up to about 140mph, where some moderate vibration occoured that was hard to tell where it was coming from but did quieten quit alot if i went on the throttle and got worse backing off or just fethering it, but since i dont go that fast very often i didnt worry too much at the time as i said the uj looked fine and i recently rebuilt the front one.


then i broke an exhaust mount got it welded and found i had really bad vibs at 60-70mph which turned out to be the exhaust on the bumper .. mostly
After i sorted that i found, while testing the previous hard to pin down high speed vibration seemed to have moved to the 110-120 mph zone and gets slowly worse going faster but still changes with the throttle.
 so i had a poke around while fitting my accusump, and the center bearing had some signs of wear already, and there is some noticable play in the rear uj too not much but it moves by hand without much effort.

can anyone confirm my suspicions that this play in the uj and preamature wear in the center bearing is most likely the culpriit before i pull it all apart again ?

oh and can anyone tell me the size of the rear uj please
5
Parts For Sale / Re: For sale emerald K6 wiring loom for 24v cosworth engine
« Last post by do0ps on January 03, 2019, 14:34:09 PM »
Hi, I bought this loom from Pete. It’s an old advert, and I’m just replying to make you aware it’s sold.

In the middle of replacing my standard management with the new Emerald stuff.

Thanks
Kris


Sent from my iPhone using Tapatalk
6
Hi again
   I left a message about your wiring loom and then noticed you have other ads. All of which are of interest to me. Please let me know what you have left as I am in the process of a bob/mt75 conversion and would be interested in a job lot.
Regards
Rod
7
Hi
   How much are you looking at for this loom please?
Regards
Rod
8
General Discussion / Re: She's looking good now
« Last post by scud on December 29, 2018, 15:41:50 PM »
Having clearance issues at Front

Sent from my HTC One M8s using Tapatalk

9
General Discussion / Re: She's looking good now
« Last post by capri v8 driver on December 29, 2018, 10:18:40 AM »
Looking good but I would lower it a bid. :2tu:
10
Members Cars / Re: 24v turbo 4x4 MK3 escort
« Last post by bigro007 on December 29, 2018, 02:55:43 AM »
ah ok
because i didn't see any of his post that is why ok not a problem thank
Pages: [1] 2 3 ... 10
SMF spam blocked by CleanTalk